ERP Software for Australian BusinessJim2® Business Engine
Version 4.2

Build 6082
Wednesday 08 Aug 2018


Happen Business is proud to offer you the latest version of Jim2 Business Engine, available to all editions, and ready for immediate download. 

Summary of features Version 4.2 includes:

  • Major updates to user security that include new 'effective' security roles and enhanced overall visibility of individual and role-specific security profiles.
  • New user groups functionality, trackable reports, greatly enhanced history and logging.
  • Items enhancement to assign users based on User Groups.
  • New multilevel manufacturing functionality to perform fixed cost manufacturing, and capture each layer of the manufacturing process in Jim2.
  • New accounts option to nominate GST country as Australia, New Zealand or South Africa.
  • New region-specific settings to nominate what you call ABN, suburb, state and postcode.
  • New CardFile functionality to nominate multiple email contacts for invoicing, statements and purchases.
  • New Ship Cards tab to CardFiles, which displays all associated shipping CardFiles and contact details.
  • Limit increased from 20 to 25 lists open in the Nav Tree per object.
  • New Current Locks tab which displays existing locked objects, as well as all active users.
  • Expanded stock search options that includes detailed description.
  • New option to create a copy of an existing email template.
  • New email rules action to 'Execute Script' for execution of server-side script for a given email.
  • New email rules action to 'Process with MPS connector' to process an email and pass it through for processing via an MPS Connector.
  • New Daily rate-based meter and Base rate meter to Managed Print Services Edition.
  • Additional function keys to speed up taking payments and invocing.
  • Jim2 Client now uses much less memory, and is faster at reloading lookups.
  • Jim2 Server is now much faster at backups where native SQL compression is available (eg. non-Express versions.) 
  • And much more...

We strongly recommend that you read the Jim2 v4.2 Release Notes provided below prior to performing the upgrade.

IMPORTANT! Before upgrading, please make sure you know your Microsoft SQL Server 'sa' user password. If you are unsure of this password, please contact your IT support first to verify it before proceeding.

top

Are you upgrading from v3.3 or an earlier version?

As Jim2 v4.0 onwards features a new scripting engine behind the scenes, it is critical that those running earlier versions of Jim2 to perform the upgrade custom scripts process, and read the latest technical requirements to move to the latest version of Jim2.

For existing Managed Print Services customers upgrading to the latest version from v4.0 or earlier, read the Managed Print Services System Administrators document, which outlines how to merge contract templates updates and more, in your transition to the latest version.

top

Release Notes and Update File


NOTE:
This download applies to all Jim2 On Premises Editions – Premium, Managed Print Services, and Managed Services.

Important: Server Operating System and Microsoft SQL

Before upgrading, the Server operating system and Microsoft SQL must have the latest Service Packs installed.

In particular, Server 2008R2 (This includes SBS2011) must have the latest Service Pack and .Net Framework 4.6.2 or 4.7.X installed (recommended for all OS’s).

When logging into Jim2, if you receive an alert that your SQL Drivers are required to be updated, the download links to do so are provided below.

If you have a terminal server, be sure to read the 'Jim2 bootstrap service for Terminal Servers' section of the release notes as it explains why and how to install the service.

To update to the new version it is likely that you will need to update the SQL Workstation drivers.



Please follow the links below to obtain the necessary updates:

SQL Driver update (X64/64Bit)
SQL Driver update (X86/32Bit

Please ensure you have a copy of the current release notes for both v4.1 and v4.2, and read the 'Jim2 Server Prerequisites' section prior to upgrading Jim2. You will then need to perform the following steps:

  1. Back up your database.
  2. Make sure that all Jim2 users are logged off.
  3. **Retail EFT users, please be sure to upgrade your Jim2 EFTPOS Server to the latest when upgrading from Jim2 v4.0 (see Jim2 EFTPOS Server below).
  4. Proceed with this update, during which you will be required to stop Jim2 Server. 

If you have any questions or issues downloading the upgrade, please contact the Happen Support Team immediately via support@happen.biz

top

Not ready to upgrade?

If you're experiencing obstacles from your hardware, MS SQL licencing or Windows versions before upgrading Jim2, perhaps our Jim2.Cloud platform is for you.

With MS SQL Licencing covered and Jim2 upgrades performed for you, take a look at the Jim2.Cloud Technical Requirements for workstations and internet access to see if Jim2.Cloud would better suit your business.

Contact Happen Sales Team at sales@happen.biz to find out more.

top

Jim2® eBusiness Framework (Jef)

The Jim2 eBusiness Framework is included with the Jim2 upgrade, however, you will need to separately upgrade your website if you are using the Jim2 eBusiness Framework.



top

Jim2 EFTPOS Server

V4.1 Build 69

The Jim2 EFTPOS server is required for on premises PCEFTPOS integration in Jim2 (not Tyro integration), and must be upgraded to Jim2 EFTPOS Server 4.1 when moving from Jim2 v4.0 to Jim2 v4.1 and v4.2..

For more information on Jim2 EFTPOS Integration, please contact your Happen Account Manager.